***有使用CCD者請注意***

我之前有貼過相關訊息,現在再重新公告一次,如果你有使用CCD,不管是類比或數位,假如你需要使用到MAX底下的ROI參數請特別注意,就是ROI的參數會自動更新為0或8,這是因為更新DAQ7.4版驅動程式的關係,如果很不幸的有人遇到這樣的問題,那麼建議方式是將所有NI的driver重新uninstall再install,DAQ的driver安裝7.3版的即可,至於為什麼會有這樣的問題以及DAQ幾版以後會修正這個BUG,請洽NI ancle38543.5146527778

請問你說的ROI指的是acquisition window嗎

因為我也遇到了相同的問題我希望的寬跟高是640*480(我有按SAVE)

但是不知為何重新執行MAX的時候都會變成8*1

另外我如果用一張卡接兩支CCD的話當我按下auto exposure時

原本清楚的畫面會馬上模糊據說是IMAQ裡面的DATA裡的這個檔壞掉         60HZ progressive scan (1409).icd

看到你的文章後我馬上把DAQMX7.4移除

再試了一下....發現並沒有得到改善喔

請問還有其他辦法嗎!!

p2002yu1024b38542.503900463

1.我第一篇裡的紅色文字,有說明是將所有driver都移除,單獨移除DAQ7.4並沒有辦法解決問題

在新增移除程式裡>>National Instruments Software>>變更,除了LabVIEW不用移除外,建議移除其他所有driver

![](upload://845xAsvkIW8ROFkxH4o5BkNVirk.jpeg)

2.按Auto Exposure後,畫面會模糊的問題,應該是跟你的光源調整有關係,請試

著先將光源亮度調到最亮,再按一次Auto Exposure看畫面是否還會模糊

 

To p2002yu1024b:

不知道您的問題有沒有解決了,以下是新版的DAQmx 7.5,有興趣的話您可以試試,可是從文件我看不出來有更正我所敘述的問題

http://www.labview.com.tw/forum/forum_posts.asp?TID=3779&FID=88

謝謝你的回覆~~

不過我的問題還是沒解決

而且我max下的imaq的參數設定還是一樣有問題

除了不能存檔之外我現在也不敢按Auto Exposure

只好將就著使用了

不知道ni改善這個問題了嗎

NI-IMAQ 3.1.3已經修正這個bug

NI-IMAQ Version 3.1.3 for Windows 2000/NT/XP

http://digital.ni.com/softlib.nsf/websearch/CD7
EAFE90E9E47398625703000754A12

Download(s):
NIIMAQ313.zip (125MB)
readme.rtf (6kB)

Product Line: Vision

Version: 3.1.3

Category: Driver

Platform(s): Windows 2000; Windows NT; Windows XP

Description:

This download is a full installer for NI-IMAQ 3.1.3. Download and unzip the attached zip file to a temporary directory and run setup.exe to install the driver. NI-IMAQ 3.1.3 includes the following new features and bug fixes:

  • Support for additional cameras with the NI PCIe-1429
  • Support for extended memory allocation with the NI PCIe-1429
  • Fix for Measurent and Automation Explorer (MAX) interface for NI-IMAQ. This bug typically caused the acquisition window controls to revert to (0, 0, 8, 1) and the timeout value to 0ms.

Compression: WinZip

Date: 2005/06/30

ancle38582.3828356481